В ядре Linux найдена локальная уязвимость

24.01.2012 | 11:00
В ядре Linux найдена локальная уязвимость
В ядре Linux найдена опасная уязвимость, позволяющая локальному злоумышленнику выполнить код с правами пользователя root (при наличии доступной пользователю SUID root программы, такой как, например, /bin/su), сообщает opennet.ru.

Проблема наблюдается начиная с ядра 2.6.39. Уязвимость также проявляется для ядра, используемого в RHEL 6. На данный момент уже опубликовано три рабочих эксплоита. Уязвимости присвоен номер CVE-2012-0056. Источником уязвимости является ошибка в реализации proc-интерфейса для прямого доступа к памяти процесса (/proc/pid/mem). В ядре 2.6.39 защита против неавторизованного доступа к этому файлу была признана неэффективной, поэтому "#ifdef" для защиты от записи в случайные области памяти был убран, вместо этого была добавлена проверка правильных разрешений на доступ.

Как оказалась, проверка привилегий была выполнена некорректно, что позволяет локальному пользователю получить права суперпользователя в ядрах 2.6.39 и выше (исключая GIT snapshot, в котором данная уязвимость была на днях закрыта).

На данный момент ни один из дистрибутивов данную ошибку не закрыл. Обновления для Red Hat и Ubuntu планировалось выпустить завтра, но в ситуации появления эксплоита в публичном доступе, процесс выпуска обновлений будет форсирован и скорее всего они выйдут уже сегодня. В число уязвимых попадают относительно недавно выпущенные дистрибутивы, поставляемые с ядрами 2.6.39, 3.0, 3.1 и 3.2 - Fedora 16, Ubuntu 11.10, OpenSUSE 12.1, Arch Linux, Gentoo и т.п.
ядро, Linux, локальная уязвимость
По материалам uinc.ru
Лента новостей: FacebookLiveJournalЯндекс

Комментарии (0)
Оставьте комментарий:CaptchaОбновить проверочный код