Cisco исправила в своих продуктах уязвимость, раскрытую три года назад

24.10.2014 | 10:29
Компания Cisco выпустила обновления для ряда своих продуктов, исправляющие уязвимость, которая была обнаружена в FreeBSD около трех лет назад. Брешь в протоколе Telnet позволяет неавторизованному атакующему удаленно выполнить произвольный код, а эксплоит для нее доступен уже в течение нескольких лет.

Уязвимость была раскрыта экспертами из FreeBSD Project в декабре 2011 года, однако недавно исследователь безопасности Глафкос Хараламбус (Glafkos Charalambous) обнаружил ее в продуктах безопасности Cisco, в том числе в Web Security Appliance, Email Security Appliance и Content Security Management Appliance. Как сообщает Threatpost, брешь присутствует в используемом этими решениями ПО AsyncOS и затрагивает все версии продуктов.

Уязвимость существует из-за недостаточной проверки ключа шифрования в демоне telnetd. Удаленный атакующий может эксплуатировать ее путем отправки вредоносных запросов на целевую систему и выполнить код с повышением привилегий. Для успешного осуществления атаки в уязвимых продуктах должен быть активирован сервис Telnet.

Cisco выпустила обновленную версию ПО AsyncOS и дала пользователям несколько дополнительных рекомендаций.

«Для некоторых версий программного обеспечения Cisco AsyncOS для Cisco ESA and Cisco SMA сервис Telnet настроен на порт управления. Для того чтобы устранить эту уязвимость, можно отключить Telnet. Администраторы могут сделать это путем администрирования графического интерфейса пользователя (GUI) или с помощью команды interfaceconfig в интерфейсе командной строки (CLI). В целях безопасности вместо Telnet рекомендуется использовать Secure Shell (SSH)», - сообщается в уведомлении Cisco.

Подробнее ознакомиться с описанием уязвимости можно по адресу: http://www.securitylab.ru/vulnerability/413004.php
уязвимость, исправления, обновления
По материалам securitylab.ru
Лента новостей: FacebookLiveJournalЯндекс

Комментарии (0)
Оставьте комментарий:CaptchaОбновить проверочный код